PoMoCo 2.0 Beta!

Re: PoMoCo 2.0 Beta!

Postby nextstep » Tue May 19, 2015 4:25 pm

ku4tp wrote:I was able to test Hexy under Linux yesterday. Connection was OK - no notable problems. The centering wizard worked OK, but some of the servos not being adjusted jittered from time to time. When I tried basic moves - get up, forward, back, point, type, etc - there was a definite lag as the move was executed. It was consistent with most moves, but the lag itself varied from one execution to another. In other words, a forward move might lag quite a bit while the next forward move would have less of a lag, Or the other way around.

I also managed to get the GUI to start and connect to Hexy on Linux (Crunchbang, a Debian variant).

But it's not operating nearly as smoothly as on OS X (PoMoCo V1). And the robot image is also not loading as you've mentioned.
nextstep
 
Posts: 10
Joined: Sun Apr 05, 2015 7:28 am

Re: PoMoCo 2.0 Beta!

Postby ku4tp » Thu May 21, 2015 10:52 am

Thanks for the additional Linux testing. I thought I might be the only one. :)
ku4tp
 
Posts: 12
Joined: Tue Feb 17, 2015 10:02 pm

Re: PoMoCo 2.0 Beta!

Postby SagesOfRPG » Fri May 29, 2015 6:24 pm

I am getting an error on my Macbook Pro

Code: Select all
Last login: Fri May 29 14:18:56 on ttys002
Wayne-Moulton-Jrs-MacBook-Pro-Retina:~ WaynesMac$ cd '/Users/WaynesMac/Downloads/PoMoCo-2-master/' && '/usr/local/bin/pythonw' -d  '/Users/WaynesMac/Downloads/PoMoCo-2-master/PoMoCo.py'  && echo Exit status: $? && exit 1
Traceback (most recent call last):
  File "/Users/WaynesMac/Downloads/PoMoCo-2-master/PoMoCo.py", line 1, in <module>
    import GUI
  File "/Users/WaynesMac/Downloads/PoMoCo-2-master/GUI.py", line 2, in <module>
    import wx
  File "/usr/local/lib/wxPython-3.0.2.0/lib/python2.7/site-packages/wx-3.0-osx_carbon/wx/__init__.py", line 45, in <module>
    from wx._core import *
  File "/usr/local/lib/wxPython-3.0.2.0/lib/python2.7/site-packages/wx-3.0-osx_carbon/wx/_core.py", line 4, in <module>
    import _core_
ImportError: dlopen(/usr/local/lib/wxPython-3.0.2.0/lib/python2.7/site-packages/wx-3.0-osx_carbon/wx/_core_.so, 2): no suitable image found.  Did find:
   /usr/local/lib/wxPython-3.0.2.0/lib/python2.7/site-packages/wx-3.0-osx_carbon/wx/_core_.so: no matching architecture in universal wrapper


Ideas?
SagesOfRPG
 
Posts: 18
Joined: Thu Oct 11, 2012 3:12 am

Re: PoMoCo 2.0 Beta!

Postby ncie-idx » Fri Jun 26, 2015 7:34 am

I'm experiencing the same issue as SagesOfRPG. Wondering if there's any pointers? It seems to be an issue with loading the wxPython Carbon.

I've installed the latest version (wxPython3.0-osx-carbon-py2.7) and am getting a very similar error:

Code: Select all
File "PoMoCo.py", line 1, in <module>
    import GUI
  File "/Applications/Arduino-Robots/PoMoCo-2/GUI.py", line 2, in <module>
    import wx
  File "/usr/local/lib/wxPython-3.0.2.0/lib/python2.7/site-packages/wx-3.0-osx_carbon/wx/__init__.py", line 45, in <module>
    from wx._core import *
  File "/usr/local/lib/wxPython-3.0.2.0/lib/python2.7/site-packages/wx-3.0-osx_carbon/wx/_core.py", line 4, in <module>
    import _core_
ImportError: dlopen(/usr/local/lib/wxPython-3.0.2.0/lib/python2.7/site-packages/wx-3.0-osx_carbon/wx/_core_.so, 2): no suitable image found.  Did find:
   /usr/local/lib/wxPython-3.0.2.0/lib/python2.7/site-packages/wx-3.0-osx_carbon/wx/_core_.so: no matching architecture in universal wrapper
ncie-idx
 
Posts: 3
Joined: Fri Jun 26, 2015 7:30 am

Re: PoMoCo 2.0 Beta!

Postby Christian79 » Mon Jun 29, 2015 2:12 am

I am also having the exact same issues as the previous two posters.
I am using a iMac running the OS X 10.10.3, Python 2.7.10 and wxPython 3.0.2.0.
Christian79
 
Posts: 1
Joined: Tue Mar 17, 2015 1:23 am

Re: PoMoCo 2.0 Beta!

Postby mikasami » Fri Oct 23, 2015 3:52 pm

Same issues as the previous 3 or 4 posters on macbook pro 10.10.5
mikasami
 
Posts: 7
Joined: Fri Jun 26, 2015 6:30 am

Re: PoMoCo 2.0 Beta!

Postby millahjovich » Wed Jun 15, 2016 9:50 am

This is a good place. Direct issues should be submitted on github:
↓https://github.com/ArcBotics/PoMoCo-2/issues/
millahjovich
 
Posts: 4
Joined: Wed Jun 15, 2016 7:52 am

Previous

Return to ArcBotics Announcements

Who is online

Users browsing this forum: No registered users and 1 guest

cron