SparkiDuino 1.0.5.4 Update (Feb 17th)

The Easy Robot for Everyone!

Re: SparkiDuino 1.0.5.4 Update (Feb 17th)

Postby roboalchemist » Tue Feb 18, 2014 6:09 pm

fixed problem with moveRight() commands, see original post or start page for link.

I'll add a page in the getting started so that people can download older releases if they like.

There were some more serious bugs that needed to have an update pushed as fast as we could (LCD, for example), but now that things are getting stable, I'll leave the start page alone unless there are well tested major feature changes (as should be the case).

I'll also start releasing a 'github current' build link. People can help me test with that if they'd like.

I'm getting to a point with build installers set up on remote servers where I'll be able to release updated builds almost as soon as they hit the github. I've been hampered until now by ridiculously slow and firewalled Chinese internet. (uploading 150MB of installers at 10KB/s doesn't work so well). We recently just moved to Hong Kong for a while so I can get internet fast enough to get US-server based automatic builds set up. It will also helps us immensely in getting more documentation up faster.
---
Joseph Schlesinger - ArcBotics Co-Founder/CTO
roboalchemist
Site Admin
 
Posts: 669
Joined: Mon Jul 16, 2012 3:02 am

Re: SparkiDuino 1.0.5.4 Update (Feb 17th)

Postby 8-Bits » Tue Feb 18, 2014 6:21 pm

@roboalchemist

Does this change also include the 2x speed change you referenced here: viewtopic.php?f=17&t=889#p5089

If not, please let me know how to make that change at the individual software component level.

Thanks,
John

Current Operating Environment
Sparki Library used: Sparki_Library_1.0.5.5.zip
Sparki.h modified date: 20141130 @ 15:08
Sparki.cpp modified date: 20141130 @ 15:08
Computer OS: Windows 7 64-bit and 8.1 64-bit
8-Bits
 
Posts: 39
Joined: Tue Jul 30, 2013 2:47 pm
Location: Tinkering in Florida, USA

Re: SparkiDuino 1.0.5.4 Update (Feb 17th)

Postby roboalchemist » Tue Feb 18, 2014 6:24 pm

Yes, that change was already made with the original update, just not the way you made it:

https://github.com/ArcBotics/Sparki/com ... 785faeaef3
---
Joseph Schlesinger - ArcBotics Co-Founder/CTO
roboalchemist
Site Admin
 
Posts: 669
Joined: Mon Jul 16, 2012 3:02 am

Re: SparkiDuino 1.0.5.4 Update (Feb 17th)

Postby Rwardjr5 » Tue Feb 18, 2014 11:05 pm

5:50 eastern time. Reloaded Sparki software to get the latest revision. rev. b. I got so far as to load the board (tools) (boards) (Arcbotics Sparki) nothing happens. I proceeded assuming that went ok. I tried to select Serial Port, but can't. I would guess that this is because the boards are not loading. checked on the file in the software. C:\Program files(x86)\SparkiDuino\hardware\arduino\boards it is dated today Feb. 18, 2014. I am at a loss as to what to do next. when I try to compile a sketch and upload it I get an error "Couldn't find a Leonardo on the selected port. Check that you have the correct port selected." need help again. thanks. oh yes, the drivers are not loading. I get the message that they were not successfully loaded.
Rwardjr5
 
Posts: 43
Joined: Wed Feb 12, 2014 1:47 am

Re: SparkiDuino 1.0.5.4 Update (Feb 17th)

Postby dave1700 » Wed Feb 19, 2014 1:37 am

I'm having problems with the updated programs. Everything worked great with the original install, then when I tried loading any of these updates, none of the USB drivers will install and the Sparki Bootloader won't install. I'm running it under Windows XP, and the driver installation says none of these drivers are approved. Oh well, it was a lot of fun while it was working. I'm at about 3 hours now trying to get it back to the original install.

(Update: It's back and running under 1.0.5.3. It's a lot of fun. Hope you can take a look at the driver install issues for some of the next updates.)

(Update 2: Interesting issue - now every time I plug in the USB to upload a routine, the com port changes randomly (ports 3, 4, 5 or 6) and since the Bootloader etc are com port specific, it says that they aren't there for the new com port) Am I just having XP issues? I've never seen this type of behavior with any USB device before.

(Update 3: I give up. I've done 3 windows system restores, and uninstalled and reloaded the program more times than I can count, in all the variations. The communication programs between Windows XP and the Sparki board just isn't reliable enough to be used on my computer. I'm going to put this away for a couple of weeks to see what happens. I really like the hardware and in just the short while it was working I learned enough about the coding to really get me excited. But, since I can't get any of the code into the Sparki, I'm just not having any fun anymore.)

(Update 4): Version c seems to be working fine. Thanks for the fix.
Last edited by dave1700 on Tue Feb 25, 2014 3:33 pm, edited 1 time in total.
dave1700
 
Posts: 8
Joined: Wed Feb 19, 2014 1:30 am

Re: SparkiDuino 1.0.5.4 Update (Feb 17th)

Postby Zax » Wed Feb 19, 2014 2:25 pm

Rwardjr5 wrote:5:50 eastern time. Reloaded Sparki software to get the latest revision. rev. b. I got so far as to load the board (tools) (boards) (Arcbotics Sparki) nothing happens. I proceeded assuming that went ok. I tried to select Serial Port, but can't. I would guess that this is because the boards are not loading. checked on the file in the software. C:\Program files(x86)\SparkiDuino\hardware\arduino\boards it is dated today Feb. 18, 2014. I am at a loss as to what to do next. when I try to compile a sketch and upload it I get an error "Couldn't find a Leonardo on the selected port. Check that you have the correct port selected." need help again. thanks. oh yes, the drivers are not loading. I get the message that they were not successfully loaded.


Confirming that I'm having the same problem with a Win 7 computer.
I noticed in the Device Manager when I plug in Sparki, it shows Sparki Bootloader under Ports - COM & LPT for a few seconds but then that disappears and I get USB IO Board under Other Devices.

Tried installing 1.0.5.4a on top and also uninstalling and reinstalling 1.0.5.4a without success. I get an error:

==========
Unable to execute file:
D:\Program Files(x86)\SparkiDuino\drivers\dpinst-amd64.exe

CreateProcess failed; code 2.
The system cannot find the file specified.
===========

I have an Intel processor, don't know if that matters.
Marc / Zax

Operating Environment

Sparki Library used: Sparki.Driver-1.0.5.4c-Setup.exe
Sparki.h modified date: 20140217 @ 09:20
Sparki.cpp modified date: 20140219 @ 01:32
Computer OS: Windows 7 Pro x64
Notes: RoboRealm not used
Zax
 
Posts: 25
Joined: Sat Feb 08, 2014 9:11 pm

Re: SparkiDuino 1.0.5.4 Update (Feb 17th)

Postby atleb » Wed Feb 19, 2014 8:54 pm

I'm also getting a hard stop in the install on windows 7 (home premium)
says no file found for installing the drivers C:\Program Files (x86)\SparkiDuino\drivers\dpinst-amd.exe
the sparkiDuino software starts off fine, and says that sparki is connected on Com 1...before I plug in the sparki
no other effect or change from plugin it in - not in the app, not under ports or usb controllers

yes, tried rebooting, over and over
tried installing the 1.0.5.4a version instead of the b
even tried downloading and running the dpinst-amd file from the Arduino github page
:cry:

Update
three more reboots, running the sparki drivers exe from here in the forum (it should be on the intro page as well...),
saying yes to two big red security warnings from MS (good luck getting that past school admins), and it got a connection on com3


/that it failed to upload with a funky msg is almost a win
avrdude: error: buffered memory access not supported. Maybe it isn't a butterfly/AVR109 but a AVR910 device?
atleb
 
Posts: 4
Joined: Wed Feb 19, 2014 8:14 pm

Re: SparkiDuino 1.0.5.4 Update (Feb 17th)

Postby roboalchemist » Thu Feb 20, 2014 7:10 am

Updated to c edition, all driver issues as a resultof the installer should be solved now, especially for Win8 users.
---
Joseph Schlesinger - ArcBotics Co-Founder/CTO
roboalchemist
Site Admin
 
Posts: 669
Joined: Mon Jul 16, 2012 3:02 am

Re: SparkiDuino 1.0.5.4 Update (Feb 17th)

Postby Zax » Thu Feb 20, 2014 5:24 pm

roboalchemist wrote:Updated to c edition, all driver issues as a resultof the installer should be solved now, especially for Win8 users.

Version c is working for me.
The only thing I've seen for people to look out for is to wait maybe 20-30 seconds after plugging in Sparki for the COM port to settle in. I've had it initially appear as COM3, get a failure on uploading a sketch, only to find that the COM port has changed to COM6. Then it stays at COM6 until the next time I disconnect/reconnect Sparki.
Marc / Zax

Operating Environment

Sparki Library used: Sparki.Driver-1.0.5.4c-Setup.exe
Sparki.h modified date: 20140217 @ 09:20
Sparki.cpp modified date: 20140219 @ 01:32
Computer OS: Windows 7 Pro x64
Notes: RoboRealm not used
Zax
 
Posts: 25
Joined: Sat Feb 08, 2014 9:11 pm

Re: SparkiDuino 1.0.5.4 Update (Feb 17th)

Postby 8-Bits » Thu Feb 20, 2014 5:36 pm

Zax wrote:
roboalchemist wrote:Updated to c edition, all driver issues as a resultof the installer should be solved now, especially for Win8 users.

Version c is working for me.
The only thing I've seen for people to look out for is to wait maybe 20-30 seconds after plugging in Sparki for the COM port to settle in. I've had it initially appear as COM3, get a failure on uploading a sketch, only to find that the COM port has changed to COM6. Then it stays at COM6 until the next time I disconnect/reconnect Sparki.

I tested the new driver installation (version "c") on both Win7 (64-bit) and Win8.1 (64-bit) computer systems and it works fine; and it should be noted that there are now 3 driver installs completed with the new version.

Note: There appears to be a two stage process on Sparki power-up where the "bootloader" starts by connecting to COMx and then the USB/Serial connection is made using COMy. The COMy USB connection ("Sparki Programed") remains active which is what Arduino IDE needs to use.
John

Current Operating Environment
Sparki Library used: Sparki_Library_1.0.5.5.zip
Sparki.h modified date: 20141130 @ 15:08
Sparki.cpp modified date: 20141130 @ 15:08
Computer OS: Windows 7 64-bit and 8.1 64-bit
8-Bits
 
Posts: 39
Joined: Tue Jul 30, 2013 2:47 pm
Location: Tinkering in Florida, USA

PreviousNext

Return to Sparki

Who is online

Users browsing this forum: Eng.teto and 4 guests