Can't do first tutorial please help

The Easy Robot for Everyone!

Can't do first tutorial please help

Postby Kaibustu » Tue Mar 14, 2017 2:03 am

I'm trying to do the first tutorial where you make sparki move forward but when I type the code from the tutorial it says "Sparki_program_test1:6: error: 'class SparkiClass' has no member named 'moveFoward'"

I tried copying it straight from the tutorial but then it said "stray '/302' in program"

What am I doing wrong? Any help is greatly appreciated! :D :D :D
Posts: 1
Joined: Tue Mar 14, 2017 1:54 am

Re: Can't do first tutorial please help

Postby roboalchemist » Tue Mar 14, 2017 3:36 am

Have you made you're selecting Sparki as your Board before you compile? ... arkiduino/

Have you tried using the 'Download Code' files directly, rather than copy-pasting? There might be a part you're accidentally leaving out in the copy-paste process: ... p?raw=true ... p?raw=true

Try using the 'Wheels' example in SparkiDuino - that code is known to work, so it's a good place to see if the problem is the code, or maybe something else with how SparkiDuino is set up.
Joseph Schlesinger - ArcBotics Co-Founder/CTO
Site Admin
Posts: 674
Joined: Mon Jul 16, 2012 3:02 am

Return to Sparki

Who is online

Users browsing this forum: Google [Bot] and 4 guests